Fork me on GitHub

Plugin Documentation

Goals available for this plugin:

Goal Description
releaser:help Display help information on multi-module-maven-release-plugin.
Call mvn releaser:help -Ddetail=true -Dgoal=<goal-name> to display parameter details.
releaser:next Logs the versions of the modules that the releaser will release on the next release. Does not run the build nor tag the repo.
releaser:release Releases the project.

System Requirements

The following specifies the minimum requirements to run this Maven plugin:

Maven 3.0.1
JDK 1.8
Memory No minimum requirement.
Disk Space No minimum requirement.

Usage

You should specify the version in your project's plugin configuration:

<project>
  ...
  <build>
    <!-- To define the plugin version in your parent POM -->
    <pluginManagement>
      <plugins>
        <plugin>
          <groupId>com.github.danielflower.mavenplugins</groupId>
          <artifactId>multi-module-maven-release-plugin</artifactId>
          <version>3.0.0</version>
        </plugin>
        ...
      </plugins>
    </pluginManagement>
    <!-- To use the plugin goals in your POM or parent POM -->
    <plugins>
      <plugin>
        <groupId>com.github.danielflower.mavenplugins</groupId>
        <artifactId>multi-module-maven-release-plugin</artifactId>
        <version>3.0.0</version>
      </plugin>
      ...
    </plugins>
  </build>
  ...
</project>

For more information, see "Guide to Configuring Plug-ins"